Kismet Wireless

Kismet Forums

 

Posted by:dinusha
Subject:[nl80211_control.o] Error 1
Date:09:46:29 18/04/2017

> Hello,
>
> As far as I know, I've corrected all the kismet dependencies. Whats up with this error after running the "make" command?
>
> Here is the entire readout:
>
> User@useless:~/kismet/kismet-2013-03-R1b$ make suidinstall
> g++ -I/usr/include/ncurses -Wall -g -O2 -c nl80211_control.cc -o nl80211_control.o
> nl80211_control.cc: In function ‘nl_handle* nl_socket_alloc()’:
> nl80211_control.cc:56:25: error: ‘nl_handle_alloc’ was not declared in this scope
> return nl_handle_alloc();
> ^
> nl80211_control.cc: In function ‘void nl_socket_free(nl_handle*)’:
> nl80211_control.cc:60:21: error: ‘nl_handle_destroy’ was not declared in this scope
> nl_handle_destroy(h);
> ^
> nl80211_control.cc: In function ‘int __genl_ctrl_alloc_cache(nl_handle*, nl_cache**)’:
> nl80211_control.cc:64:48: error: ‘genl_ctrl_alloc_cache’ was not declared in this scope
> struct nl_cache *tmp = genl_ctrl_alloc_cache(h);
> ^
> Makefile:317: recipe for target 'nl80211_control.o' failed
> make: *** [nl80211_control.o] Error 1
> eric@ltop:~/kismet/kismet-2013-03-R1b$ make install
> g++ -I/usr/include/ncurses -Wall -g -O2 -c nl80211_control.cc -o nl80211_control.o
> nl80211_control.cc: In function ‘nl_handle* nl_socket_alloc()’:
> nl80211_control.cc:56:25: error: ‘nl_handle_alloc’ was not declared in this scope
> return nl_handle_alloc();
> ^
> nl80211_control.cc: In function ‘void nl_socket_free(nl_handle*)’:
> nl80211_control.cc:60:21: error: ‘nl_handle_destroy’ was not declared in this scope
> nl_handle_destroy(h);
> ^
> nl80211_control.cc: In function ‘int __genl_ctrl_alloc_cache(nl_handle*, nl_cache**)’:
> nl80211_control.cc:64:48: error: ‘genl_ctrl_alloc_cache’ was not declared in this scope
> struct nl_cache *tmp = genl_ctrl_alloc_cache(h);
> ^
> Makefile:317: recipe for target 'nl80211_control.o' failed
> make: *** [nl80211_control.o] Error 1
>
> Any guidance is appreciated.


>Hii..
>> You should install libnl-3.0 libnl-genl-3.0 packages
>> Then Configure again with this command $ sudo ./configure --prefix=/usr -- enable-warn=off


Reply to this message