Kismet Wireless

Kismet Forums

 

Posted by:dinusha
Subject:Building on Ubuntu 16.04
Date:09:28:54 18/04/2017

> I'm trying to build on Ubuntu 16.04 but getting the libnl error:
>
> *** WARNING ***
> LibNL/nl80211 support was not found. Kismet uses libnl to control...
>
> But 16.04 uses libnl-3 and doesn't have a package for libnl:
>
> # apt-cache search libnl|grep dev
> libnl-3-dev - development library and headers for libnl-3
> libnl-cli-3-dev - development library and headers for libnl-cli-3
> libnl-genl-3-dev - development library and headers for libnl-genl-3
> libnl-idiag-3-dev - development library and headers for libnl-genl-3
> libnl-nf-3-dev - development library and headers for libnl-nf-3
> libnl-route-3-dev - development library and headers for libnl-route-3
> libnl-xfrm-3-dev - development library and headers for libnl-xfrm-3
> libnlopt-dev - nonlinear optimization library -- development package
>
> Any suggestions to get it built? I'm aiming to get an Ubertooth working so if there is an easier way to do it, happy to go that way instead.


> Hii..


> You should install libnl-3.0 libnl-genl-3.0 packages
> Then Configure again with this command $ sudo ./configure --prefix=/usr --enable-warn=off


Reply to this message