Kismet Wireless

Kismet Forums


Posted by:yuuhi
Subject:Initial Setup on Fedora 25
Date:12:19:18 04/04/2017

Well, I tried running kismet with SELinux in 'permissive' mode but it didn't help. I should have realized this because there were no AVCs being generated. In fact there's nothing in the system logs at all, yet kismet_capture was clearly failing with EPERM.

I tried a bunch of other things, too (mainly playing around with capabilities) but that didn't help either so... I gave up on the Fedora RPM, downloaded the source and rebuilt from scratch. After 'make suidinstall' it works just fine.

So I think what this may really be is some fundamental problem in the Fedora 25 package. Maybe they're just so far behind that the binaries they've built simply don't work in their own environment? I'll file a bug with their Bugzilla and see what comes of it.

Thanks very much for your help. I hope this is good news!

PS Later I think I will also try applying the SELinux labels from the policy to see if it's compatible with the working version. If so maybe it will be useful, at least as an option.

Reply to this message