Kismet Wireless

Kismet Forums


Posted by:dragorn
Subject:Initial Setup on Fedora 25
Date:00:56:23 02/04/2017

Hm that's very odd.

One theory I have - do you have system-wide selinux enabled? I think fedora sets this to on by default; I know it causes problems with Apache too.

I don't *like* this solution at all, but check the output of 'getenforce' and see if it's enforcing; that might be the problem.

You could try some of the options here:

and try either disabling selinux, or setting it to permissive mode. Neither of these options are good for your system security, but they might be a temporary fix.

If doing that solves it (or doesn't), post back here; I'll try to figure out how to make Kismet coexist with enforcing selinux if that's the blocking problem, I hate to tell you to disable such a good security measure.

> Hello,
> I've installed Kismet from the latest package available in the Fedora 25 repo, version 2013.03.R1-7.fc24. The package installs fine but kismet_capture refuses to run, and I wondered if someone has advice?
> The executable is installed setuid root:
> -rwsr-x---. 1 root kismet 7304 Feb 4 2016 kismet_capture
> And I'm executing kismet from an account 'kismet' which is in the kismet group:
> [kismet@mini ~]$ groups
> kismet
> Yet I still get
> FATAL: !!! CRITICAL ERROR !!! - Could not launch kismet_capture control binary,
> due to permission errors. To run Kismet suid-root your user MUST BE IN
> THE 'kismet' GROUP. Use the 'groups' command to show what groups your
> user is in, and consult the Kismet README for more information. - Kismet
> will not operate correctly.
> The software seems to work fine if I run kismet as root and start kismet_capture from there, so this DOES seem to be a permissions problem, but what? Is it perhaps necessary to do some kind of SELinux reconfiguration?
> [kismet@mini ~]$ ls -Z /usr/bin/kismet*
> system_u:object_r:kismet_exec_t:s0 /usr/bin/kismet
> system_u:object_r:bin_t:s0 /usr/bin/kismet_capture
> system_u:object_r:bin_t:s0 /usr/bin/kismet_client
> system_u:object_r:kismet_exec_t:s0 /usr/bin/kismet_drone
> system_u:object_r:kismet_exec_t:s0 /usr/bin/kismet_server
> Thanks for any pointers!

Reply to this message