Kismet Wireless

Kismet Forums

 

Posted by:dragorn
Subject:Spectool compile failure
Date:01:20:19 27/06/2016

Fixed in the git version, so grab the dev code until it makes it into a release and you should be fine.

-m

> Hi,
>
> I'm new to the Forum, Spectools and Linux. So, hope I'm in the right place and doing the right thing!
>
> I've been struggling with some issues for a couple of days and I hope someone might be able to help just get Spectool working with my Ubertooth One. Sorry about the long winded description, but trust it gives the info needed.
>
> Running Linux 2016 Kali GNU/Linux Rolling 64-bit
> Have downloaded and installed Spectools 2016-01-R1 for use with Ubertooth One
> Ubertooth One installed and built - all lights on indicate device working and and able to packet capture successfully in other modes.
> Have downloaded and installed all required libs noted in Spectools README and elsewhere suggested on searching for my problem via Web.
>
> The problem is, no matter what I try, I get compile error:
>
> spectool_gtk_channel.o: In function `spectool_channel_draw':
> /root/spectools-2016-01-R1/spectool_gtk_channel.c:124: undefined reference to `hsv_to_rgb'
> collect2: error: ld returned 1 exit status
> Makefile:59: recipe for target 'spectool_gtk' failed
> make: *** [spectool_gtk] Error 1
>
> I've re-tried various config settings:
> (a) ./configure - complains about missing cairo.h
> (b) CPPFLAGS=-I/usr/include/cairo ./configure as a suggestion to clear warnings
>
> In all cases, "make" then fails consistently with same issue above. I've tried installing gcc and g++ version 4.9 (there was a suggestion that the earlier version of the compiler might work) and passed those specifics to the config via CC=gcc-4.9 CXX=g++-4.9 CPPFLAGS=-I/usr/include/cairo ./configure
>
> Still unsuccessful. Please may I thank you in advance for any help / suggestions I could try.
>
> Graham


Reply to this message