Kismet Wireless

Kismet Forums

 

Posted by:dragorn
Subject:Struggling with wireless setup
Date:15:05:15 14/07/2014

The cisco and proxim cards are, at this point, absolutely ancient. You'll have much better luck with a $10 USB atheros card from amazon.

I also suspect you've got an old kismet; use the packages from the kismet site or compile from source to get the latest.

-m

> Hi,
>
>
> I am trying to setup Kismet. I am struggling with the wireless card, please.
>
> stephen@SONY ~ $ uname -a
> Linux SONY 3.2.0-64-generic #97-Ubuntu SMP Wed Jun 4 22:03:48 UTC 2014 i686 i686 i386 GNU/Linux
>
>
> stephen@SONY ~ $ ifconfig
> eth0 Link encap:Ethernet HWaddr 00:01:4a:c4:24:c9
> UP BROADCAST MULTICAST MTU:1500 Metric:1
> RX packets:0 errors:0 dropped:0 overruns:0 frame:0
> TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
> collisions:0 txqueuelen:1000
> RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
>
> eth1 Link encap:Ethernet HWaddr 00:13:ce:92:38:47
> inet6 addr: fe80::213:ceff:fe92:3847/64 Scope:Link
> UP BROADCAST PROMISC MULTICAST MTU:1500 Metric:1
> RX packets:840373 errors:0 dropped:0 overruns:0 frame:0
> TX packets:599565 errors:0 dropped:0 overruns:0 carrier:0
> collisions:0 txqueuelen:1000
> RX bytes:928562756 (928.5 MB) TX bytes:92679560 (92.6 MB)
> Interrupt:22 Base address:0x8000 Memory:b0106000-b0106fff
>
> lo Link encap:Local Loopback
> inet addr:127.0.0.1 Mask:255.0.0.0
> inet6 addr: ::1/128 Scope:Host
> UP LOOPBACK RUNNING MTU:16436 Metric:1
> RX packets:23654 errors:0 dropped:0 overruns:0 frame:0
> TX packets:23654 errors:0 dropped:0 overruns:0 carrier:0
> collisions:0 txqueuelen:0
> RX bytes:2461969 (2.4 MB) TX bytes:2461969 (2.4 MB)
>
> wlan0 Link encap:Ethernet HWaddr 00:40:96:ae:d4:d1
> inet addr:192.168.1.194 Bcast:192.168.1.255 Mask:255.255.255.0
> inet6 addr: fe80::240:96ff:feae:d4d1/64 Scope:Link
> UP BROADCAST RUNNING PROMISC MULTICAST MTU:1500 Metric:1
> RX packets:6415 errors:0 dropped:0 overruns:0 frame:0
> TX packets:3808 errors:0 dropped:0 overruns:0 carrier:0
> collisions:0 txqueuelen:1000
> RX bytes:3081533 (3.0 MB) TX bytes:618486 (618.4 KB)
>
> stephen@SONY ~ $ iwconfig
> lo no wireless extensions.
>
> eth1 IEEE 802.11bg ESSID:"Super8"
> Mode:Managed Frequency:2.412 GHz Access Point: 00:02:6F:91:8A:B4
> Bit Rate:54 Mb/s Tx-Power=20 dBm Sensitivity=8/0
> Retry limit:7 RTS thr:off Fragment thr:off
> Power Management:off
> Link Quality=51/100 Signal level=-70 dBm Noise level=-88 dBm
> Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
> Tx excessive retries:4 Invalid misc:0 Missed beacon:15
>
> wlan0 IEEE 802.11abg ESSID:"Super8"
> Mode:Managed Frequency:2.412 GHz Access Point: 00:02:6F:6D:14:E5
> Bit Rate=18 Mb/s Tx-Power=27 dBm
> Retry long limit:7 RTS thr:off Fragment thr:off
> Power Management:off
> Link Quality=35/70 Signal level=-75 dBm
> Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
> Tx excessive retries:249 Invalid misc:4386 Missed beacon:0
>
> eth0 no wireless extensions.
>
> stephen@SONY ~ $
>
>
> I have an Intel on-board WLan chip on my laptop and a Cisco Air Card in the PCMCIA slot. I also have a Proxim card, if necessary.
>
>
> I currently have listed in /etc/kismet/kismet.conf:
> source=cisco_wifix,wlan0,ciscosource
>
> I get the following result:
> stephen@SONY ~ $ sudo kismet
> Launching kismet_server: //usr/bin/kismet_server
> Suid priv-dropping disabled. This may not be secure.
> No specific sources given to be enabled, all will be enabled.
> Non-RFMon VAPs will be destroyed on multi-vap interfaces (ie, madwifi-ng)
> Enabling channel hopping.
> Enabling channel splitting.
> NOTICE: Disabling channel hopping, no enabled sources are able to change channel.
> FATAL: Invalid device pair 'wlan0'
> Done.
> stephen@SONY ~ $
>
>
> So, what needs to happen with the sources=, please?
>
> Thank You for your assistance.
>
> -SHD


Reply to this message