Kismet Wireless

Kismet Forums

 

Posted by:henrylaw
Subject:Kismet runs at home, gives "ioctl failed 22" at the survey location ... wot?
Date:16:48:18 30/01/2014

> Works fine at home; sees my own wireless and four or five others from nearby houses. Then I take it to the charity who has asked me to have a look at WiFi problems and "sudo kismet" consistently fails thus:
>
> FATAL: channel get ioctl failed 22:Invalid argument
>
> Back home again ... works perfectly. On battery or mains.

Fixed it. http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=654720 is the key.

When Kismet comes up it asks the network card what channel it's set for. If the card hasn't been connected (as is the case in my survey location) it says that it's not set at all. Kismet treats this response as an IO error and barfs.

Whereas in the case of my home network manager would immediately connect and set a channel, so Kismet's query then "worked" as far as the bring-up sequence is concerned.

It would be nice if the bug were fixed (not my skill) but as a work-round set the channel with a command like

iwconfig wlan0 channel 6

(I guess the selected channel doesn't matter), and then start Kismet.


Reply to this message