Kismet Wireless

Kismet Forums

 

Posted by:orkazaz
Subject:kismet_capture.o: file not recognized: File format not recognized
Date:15:20:35 10/11/2013

Hi,
I'm trying to compile the kismet latest source code on a Raspberry PI device (running linux) - it's a small "computer" with a wifi dongle + LAN connection..

A) First I had some errors in the ./configure part. I solved that after installing:
1. sudo apt-get install libncurses5
2. sudo apt-get install libncurses5-dev
3. sudo apt-get install libpcap0.8-dev
4. sudo apt-get install libpcre3-dev
5. sudo apt-get install libnl-dev

B) Now I ran the:
sudo make dep

Still all good.

C) Now I'm trying to run "sudo make".
I'm getting this error:
kismet_capture.o: file not recognized: File format not recognized
collect2: ld returned 1 exit status
make: *** [kismet_capture] Error 1

This error occur when trying to:
g++ -rdynamic -o kismet_capture util.o cygwin_utils.o globalregistry.o ringbuf.o packet.o messagebus.o configfile.o getopt.o filtercore.o ifcontrol.o iwcontrol.o madwifing_control.o nl80211_control.o psutils.o ipc_remote.o netframework.o clinetframework.o tcpserver.o tcpclient.o timetracker.o drone_kisnetframe.o packetsourcetracker.o packetchain.o packetsource_pcap.o packetsource_wext.o packetsource_bsdrt.o packetsource_drone.o packetsource_ipwlive.o packetsource_airpcap.o packetsource_darwin.o packetsource_macusb.o dumpfile.o dumpfile_tuntap.o kismet_capture.o -ldl -lm -lpcre -lstdc++ -lpcap -lnl

What is wrong??
I have no idea what to do next.

#####
By the way,
I'm compiling kismet and not using the "apt-get install kismet", because I want the latest version of kismet,
and by compiling the kismet auto creates the config file with the right parameters and sources..

Thank you!


Reply to this message