Kismet Wireless

Kismet Forums

 

Posted by:n0ne
Subject:gpsd works, kismet doesn't record gps location data though?
Date:00:14:20 10/08/2013

Hi,

Working on Raspberry Pi with Wheezy installed.

Have been trying for the past 48hrs to get kismet to work with gps logging and finally admitting defeat and asking for help!

Hardware
Raspberry Pi (512mb model)
Alfa AWUS036H (With additional power through a USB 'Y' splitter)
GPS is model Globalsat BU-353 via USB



When I run:

"sudo cgps"

I have a screen with what appears to be 10-13 satellites in the right hand side, and in the left it states lat/long location co-ordinates.

When I run:

"sudo kismet"

I do not have any gps co-ordinates on that screen show up, as i've seen in other images in tutorials/google images.

When I close kismet via a CTRL-C one of the things it says is:

"Didn't log any GPS coordinates, unlinking gps file"

The gps log whilst kismet is running is 260b only

The kismet.conf file is:

# Do we have a GPS?
gps=true
# Host:port that GPSD is running on. This can be localhost OR remote!
gpshost=localhost:2947
# Do we lock the mode? This overrides coordinates of lock "0", which will
# generate some bad information until you get a GPS lock, but it will
# fix problems with GPS units with

the gps is at /dev/ttyUSB0

Any help is greatly appreciated as i'm starting to lose the will to live!


Reply to this message