Kismet Wireless

Kismet Forums

 

Posted by:Cat
Subject:Install kismet on Raspberry pi ,which ncsource type should I use??Please help me!
Date:06:16:38 11/07/2013

> > I have installed kismet-2013-03-R0 on Raspberry pi.
> >
> > Hardware Platform:
> > Raspberrypi 2013-05-29-wheezy-armel.img Debian GNU/Linux 7.0
>
> > It's a usb wireless card which doesn't need driver.
> >
> > root@raspberrypi:~# lsusb
> > Bus 001 Device 004: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter
> >
>
> >
> > why kismet can't auto decte my wireless card type??
> > Any reply is ok.
>
> Most likely because raspbian and those based on it deliberately disabled the good driver in the kernel for a lot of the micro-card realtek stuff, and are shipping an out-of-kernel third party driver.
>
> Generally the out of kernel stuff doesn't have working monitor mode at all, if it does, it doesn't respond to the standard commands to control it.
>
> Your BEST bet really, and it's not the most simple, is to get the kernel source package, re-enable the in-kernel driver, and rebuild the kernel/ramdisk/etc packages that way. I'm not entirely sure off the top of my head what driver you need, it might fall under the 8192cu or the 8188es.
>
> There's also a chance that there is not currently a proper in-kernel driver for that chipset at all, in which case you're stuck with trying to figure out what driver is being loaded, and how it might support monitor mode.
>
> Your other option, which isn't free, is to just get another USB device w/ a known good driver - anything from the atheros chipset family should work fine, just google 'atheros usb' or maybe 'atheros usb linux' and you should find a wealth of choices - not knowing where you live i don't know what's convenient to order from, lately I just get wifi cards off amazon.

Thank you very much,I have solved it by change another wireless card (Atheros AR9271)


Reply to this message