Kismet Wireless

Kismet Forums

 

Posted by:Fong
Subject:Kismet configuration so that normal wifi still work
Date:07:18:46 19/06/2013

Thanks.

I managed to use the following config:
ncsource=wlan0:ignoreprimary=true,hop=false,channel=1,wpa_scan=15

to get part of the normal wifi working.

I am using Ralink RT5370 wifi adapter.
If I boot up my Raspberry Pi without the LAN connected, and connect with only Wifi. And I try to run Kismet_server, it will mess up the normal wifi.

But if boot up with the LAN connected, then connect the wifi. then I run kismet_server I can disconnect the LAN cable, and still be able to SSH to the Raspberry Pi. Now I have kismet_server running without the LAN cable attached, and I can SSH to it and run Kismet_client.

I am still trying to find a solution to start kismet_server without having to plug in the LAN cable.


> > Is there a way to configure kismet so that it can scan the network and yet normal wifi still work?
> > I have been experimenting with wpa_scan options, vap mode but everytime I run kismet_server, the network went down.
> >
> > I managed to achieve it once, but I can't remember what is the conf as the SD card got corrupted.
>
> If you set kismet to leave the master interface alone (ignoreprimary=true), set it to not channel hop the interface (hop=false) and set it to scan via wpa_supplicant, it MIGHT work.
>
> I've found that since adding the wpa_supplicant feature, a lot of drivers get unhappy making a monitor vap along a managed, even thought it SHOULD work and used to.
>
> I think it will be very driver dependent, you'll definitely want the ignoreprimary=true with 2013 kismet, because it shuts down the base interface to prevent it from interfering with channel operation.


Reply to this message