Kismet Wireless

Kismet Forums

 

Posted by:deza
Subject:open mesh om2p, openwrt and kismet
Date:19:26:12 21/05/2013

> > we have an open mesh om2p AP with the latest version of openwrt and kismet ( 2013-03-R1b) The ap is based on an atheros SOC and a atheros wireless card
> >
> > All is installed fine and i am able to put the wireless card in monitor mode, however after 20 minutes or so kismet has only picked up a couple of wireless networks and clients. Using kismet on another box there is a lot more (around 15) networks and 50 - 100 clients. I have tried a lot of different config changes etc but nothing seems to help. i have also tried running the full server on the AP instead of the drone but no difference. what is there i can try to resolve this?
> >
> > When i look at the channels details view i can see there is quite a lot of packets showing up (in the thousands) on all channels but not sure if this means anything at all.
>
> I'm going to tentatively point at the drivers / multivap setup being the problem, since there isn't much that would let kismet parse some but not others.
>
> If you want to dig deeper, try running tcpdump on wlanXmon while Kismet is running, and then look at the log file in Wireshark - if you want, compress it and email me a URL and I'll take a look at it, too.
>
> One good bet is that your other system is channel hopping, while the system running mesh code is not hopping - that will severely limit the # of packets you see. Unfortunately there's really no way to hop & be a useful mesh node (or AP).
>
> You could try turning off the mesh functionality and run Kismet w/ only a monitor mode vap created; i bet you'd see very different results.

Thanks for the quick reply, the openwrt has no mesh functionality active, it is being used for just as a scanner, i have changed the wireless config to be auto channel as i was getting channel hopping errors, they stopped after the wireless change.

i have tried with having the wireless interface in monitor mode and having a single vap set up but this didnt make a difference. im thinking it maybe a driver issue, so will check the tcpdump

Thanks


Reply to this message