Kismet Wireless

Kismet Forums

 

Posted by:nixor
Subject:TL-WN725N
Date:23:25:04 07/03/2013

> > I'm new in the Kismet.
> > I have compiled the kismet and install it.
> > However,when I run it I cannot get zhe networks.When I quit the kis met ,I can get a imformation that tell me fail to find a type for auto-type.
> > ERROR: Failed to find a type for auto-type source 'wlan0',you will have ro tell Kismet what it is by adding a type=[card type] to the ncsource config
> > ERROR:It is possible that the dvice for interface 'wlan0' is not active or was not plugged in. Kismet will ignore this interface ,you may re-add it later.
> >
> > I run Kismet on Ubuntu12-04. I set the ncsource with ncsource=wlan0:name=yan.
> >
> > Can you give me a suggest about above question?How to solve it?
> >
> > Thank you!
>
> For your kismet drone: Try to see what type of your wireless card is by command 'iwconfig' or 'iw info wlan0'
>
> Then consult the readme page (Documentation) in section 5 and 7.
>
> Basically you'd need to use smth like 'ncsource=wlan0:type=[yourcardtype]'
> ex. 'ncsource=wlan0:type=ath9k'
>
> For kismet server: I just use 'ncsource=drone,host=[routerIP],port=[kismetDronelistenPortOnRouter]'
> ex. 'ncsource=drone,host=10.0.0.1,port=2502'

So very sorry, it should have been this for the server:
'ncsource=drone:host=10.0.0.1,port=2502'

Notice it's not a comma after the parameter 'drone'. It wouldn't work otherwise.

Please refer to this document I myself find much help from:
http://www.giac.org/paper/gcih/18158/remote-access-point-ids/115738

Credit to laserpad of this forums.


Reply to this message