Kismet Wireless

Kismet Forums

 

Posted by:neoke
Subject:Kismet on OpenWrt Router with Access Point mode ?
Date:02:14:05 01/02/2013

> > > Hello everyone,
> > > I am trying to build a simple wireless IDS on Router (TP-Link WR914ND version 3 running OpenWrt).
> > > I installed Kismet Drone on it, and I can use Kismet server on Linux PC to connect to Kismet Drone.
> > > Everything was OK when Router’s wireless interface was running in Monitor mode.
> > > But I want to provide Internet Access while using Kismet to monitor my network on this Router. Is there any way to do that ?
> > > When wireless interface was running in Access Point mode, I could still use Kismet Drone on Router, but it could not hop channel, I got “ERROR: mac80211_setchannel() could not set channel 4/2427 on interface 'wlan0mon' err -25”.
> >
> > You can't channel hop and be an AP at the same time - the AP would constantly change channels.
> >
> > If you want to run wids+ap, you have to disable channel hopping.
>
> Here is a paper I wrote last year relevant to the subject that may help you with this project. Good luck
>
> http://www.giac.org/paper/gcih/18158/remote-access-point-ids/115738


Thank dragorn and laserpad for helping :-)


Reply to this message