Kismet Wireless

Kismet Forums

 

Posted by:dragorn
Subject:Kismet on OpenWrt Router with Access Point mode ?
Date:18:02:09 31/01/2013

> Hello everyone,
> I am trying to build a simple wireless IDS on Router (TP-Link WR914ND version 3 running OpenWrt).
> I installed Kismet Drone on it, and I can use Kismet server on Linux PC to connect to Kismet Drone.
> Everything was OK when Router’s wireless interface was running in Monitor mode.
> But I want to provide Internet Access while using Kismet to monitor my network on this Router. Is there any way to do that ?
> When wireless interface was running in Access Point mode, I could still use Kismet Drone on Router, but it could not hop channel, I got “ERROR: mac80211_setchannel() could not set channel 4/2427 on interface 'wlan0mon' err -25”.

You can't channel hop and be an AP at the same time - the AP would constantly change channels.

If you want to run wids+ap, you have to disable channel hopping.


Reply to this message