Kismet Wireless

Kismet Forums

 

Posted by:dragorn
Subject:Failed to set channel: invalid argument
Date:03:19:56 22/05/2012

> Hi!!
>
> Im using backtrack with rt2800usb based device.
>
> Well, in windows and using the ralink utility i can use special/super channels of 11a (like as: 100,124...), no problems!
>
> But in linux if i TRY to lock kismet in this channels i got: Failed to set channel:100 invalid argument
>
> Any ideas?

Most likely your regdomain isn't set properly; try 'iw reg <your region code>'; if BT isn't setting that.

Also make sure you're using the kernel drivers, not the out-of-kernel stuff - the non-stock modules don't really follow the wireless standards and generally misbehave.


Reply to this message