Kismet Wireless

Kismet Forums

 

Posted by:rmortim
Subject:Kismet drone WRT54GL using DD-wrt.. Help Please
Date:22:56:44 24/01/2012

> > Hi
> > Im trying to find some help with running a kismet_drone on a Wrt54Gl v1.1 (DD-WRT v24-sp2 (10/10/09) mini) and the server on linux machine runnning fedora 16.
> > Ive been struggling the past few days(As i am really noob with linux) and been going accord to http://www.dd-wrt.com/wiki/index.php/Wrt54g_kismet_with_linux_server
> >
> > Now i tried different versions of kismet and have changed the allowed hosts and source (source=wrt54g,prism0,Kismet-Drone) and get the drone running using scp to copy over the edited files.
> >
> > These are the results from the telnet when the drone is running.
> >
> > "root@DD-WRT:/tmp# /tmp/kismet_drone
> > Suid priv-dropping disabled. This may not be secure.
> > No specific sources given to be enabled, all will be enabled.
> > Disabling channel hopping.
> > Source 0 (Kismet-Drone): Enabling monitor mode for wrt54g source interface prism0 channel 0...
> > Source 0 (Kismet-Drone): Opening wrt54g source interface prism0...
> > NOTICE: bind address not specified, using INADDR_ANY.
> > Kismet Drone 2006.04.R1 (Kismet)
> > Listening on port 3501 (protocol 9).
> > Allowing connections from 10.0.0.33/255.255.255.255"
> >
> > Im supposed to make the server with these commands
> >
> > cd <download directory>
> > tar -zxvf <kismet source file>tar.gz
> > cd <kismet dir>
> > ./configure
> > make
> > make install
> >
> > I try to install the server now and get these reults
> >
> >
> >
> > "[root@Gunner kismet-2006-04-R1]# ./configure
> > checking build system type... x86_64-unknown-linux-gnu
> > checking host system type... x86_64-unknown-linux-gnu
> > checking for gcc... gcc
> > checking for C compiler default output file name... a.out
> > checking whether the C compiler works... yes
> > checking whether we are cross compiling... no
> > checking for suffix of executables...
> > checking for suffix of object files... o
> > checking whether we are using the GNU C compiler... yes
> > checking whether gcc accepts -g... yes
> > checking for gcc option to accept ANSI C... none needed
> > checking for g++... no
> > checking for c++... no
> > checking for gpp... no
> > checking for aCC... no
> > checking for CC... no
> > checking for cxx... no
> > checking for cc++... no
> > checking for cl... no
> > checking for FCC... no
> > checking for KCC... no
> > checking for RCC... no
> > checking for xlC_r... no
> > checking for xlC... no
> > checking whether we are using the GNU C++ compiler... no
> > checking whether g++ accepts -g... no
> > checking for a BSD-compatible install... /usr/bin/install -c
> > checking whether make sets $(MAKE)... yes
> > checking how to run the C preprocessor... gcc -E
> > checking for platform-specific compiler flags... none needed
> > checking whether byte ordering is bigendian... no
> > checking for egrep... grep -E
> > checking for ANSI C header files... yes
> > checking for sys/types.h... yes
> > checking for sys/stat.h... yes
> > checking for stdlib.h... yes
> > checking for string.h... yes
> > checking for memory.h... yes
> > checking for strings.h... yes
> > checking for inttypes.h... yes
> > checking for stdint.h... yes
> > checking for unistd.h... yes
> > checking errno.h usability... yes
> > checking errno.h presence... yes
> > checking for errno.h... yes
> > checking for stdlib.h... (cached) yes
> > checking for string.h... (cached) yes
> > checking sys/socket.h usability... yes
> > checking sys/socket.h presence... yes
> > checking for sys/socket.h... yes
> > checking sys/time.h usability... yes
> > checking sys/time.h presence... yes
> > checking for sys/time.h... yes
> > checking sys/wait.h usability... yes
> > checking sys/wait.h presence... yes
> > checking for sys/wait.h... yes
> > checking for unistd.h... (cached) yes
> > checking for sys/types.h... (cached) yes
> > checking netdb.h usability... yes
> > checking netdb.h presence... yes
> > checking for netdb.h... yes
> > checking getopt.h usability... yes
> > checking getopt.h presence... yes
> > checking for getopt.h... yes
> > checking for an ANSI C-conforming const... yes
> > checking whether time.h and sys/time.h may both be included... yes
> > checking whether struct tm is in sys/time.h or time.h... time.h
> > checking for ANSI C header files... (cached) yes
> > checking return type of signal handlers... void
> > checking whether lstat dereferences a symlink specified with a trailing slash... yes
> > checking whether stat accepts an empty string... no
> > checking for gettimeofday... yes
> > checking for memset... yes
> > checking for select... yes
> > checking for socket... yes
> > checking for strcasecmp... yes
> > checking for strftime... yes
> > checking for strstr... yes
> > checking for system-level getopt_long()... yes
> > checking for stdint.h... (cached) yes
> > checking for accept() addrlen type... socklen_t
> > checking for special C compiler options needed for large files... no
> > checking for _FILE_OFFSET_BITS value needed for large files... no
> > checking for _LARGE_FILES value needed for large files... no
> > checking for main in -luClibc++... no
> > configure: WARNING: uclibc++ not available on this system
> > checking for main in -lstdc++... no
> > configure: WARNING: libstdc++ not available on this system
> > configure: error: Neither uclibc uClibc++ or standard gcc stdc++ libraries found.
> > [root@Gunner kismet-2006-04-R1]#"
> >
> > If i try the command make after this i get this result
> >
> > "[root@Gunner kismet-2006-04-R1]# make
> > make: *** No targets specified and no makefile found. Stop."
> >
> > So im to sure if there is a target file i should put on the end of that command or if there is a issue when i try configure?
> >
> > If anyone can provide any help or be able to assist with source files they have got working with this router and any firmware and a how to instructions?
> >
> > Thank you
> > Ross
>
>
> On your dd-wrt device config, ensure that the line dronelisten=tcp://127.0.0.1:3501 has the IP address of your device (or interface) otherwise you get this warning. NOTICE: bind address not specified, using INADDR_ANY.
>
> On your server, ensure that you have one of the following libraries listed in the error message installed or you will get the following error as seen above.
> error: Neither uclibc uClibc++ or standard gcc stdc++ libraries found.
>
> Now you can try to rerun ./configure, and if it is successful, it will create that makefile so you can proceed with the make command.
> *On a side note, it is more secure if you rerun ./configure as your local user, then 'make' as your local user, and 'sudo make install' to install the server. Also ensure that your local user is part of the kismet group if you use this method so that the server can run with the appropriate permissions.


Thanks, I managed to get the file configured by installing the libaries.
But having a issue with the make command after that. Sorry still learning my way here :$
Below is the error i receive after configuring and trying to make?


bullet@gunner:~/Desktop/kismet-2006-04-R1$ sudo make dep
make[1]: Entering directory `/home/bullet/Desktop/kismet-2006-04-R1'
make[2]: Entering directory `/home/bullet/Desktop/kismet-2006-04-R1'
make[2]: `.depend' is up to date.
make[2]: Leaving directory `/home/bullet/Desktop/kismet-2006-04-R1'
make[1]: Leaving directory `/home/bullet/Desktop/kismet-2006-04-R1'
bullet@gunner:~/Desktop/kismet-2006-04-R1$ make
g++ -Ilibpcap-0.9.1-kis -O2 -Wall -DVERSION_MAJOR=\"2006\" -DVERSION_MINOR=\"04\" -DVERSION_TINY=\"R1\" -DTIMESTAMP=\"`cat TIMESTAMP`\" -g -O2 -g -O2 -c util.cc -o util.o
In file included from util.cc:21:0:
util.h:68:2: warning: ‘typedef’ was ignored in this declaration [enabled by default]
util.cc: In function ‘int Hex2UChar(unsigned char*, unsigned char*)’:
util.cc:116:57: error: ‘memset’ was not declared in this scope
util.cc: In function ‘int RunSysCmd(char*)’:
util.cc:251:19: warning: ignoring return value of ‘int system(const char*)’, declared with attribute warn_unused_result [-Wunused-result]
make: *** [util.o] Error 1


Reply to this message