Kismet Wireless

Kismet Forums

 

Posted by:laserpad
Subject:Hidedata
Date:08:43:47 22/12/2011

> > I have a router with enough space for both kismet server (with drone capabilities) and drone so I can detect and export data, but noticed that the drone wouldn't export layer 3 data over the virtual interface and the server would, so I added hidedata=false to the drone configuration file since I remembered it from the server configuration file and it started working. Can this line be added to the drone in the future or documented so noone has to troubleshoot this again? or is there a better way to get layer 3 data from the drone that I missed?
>
> That doesn't make much sense...
>
> Hidedata doesn't default to enabled - if it's not present, it will be considered 'false'.
>
> But even more telling - there is no hidedata option on the drone. Nothing in the drone parses that option, and nothing in the drone *could* process that option. Hidedata implements in the 802.11 dissector, which occurs ONLY in the server. The drone blindly copies packets and doesn't try to dissect them - hidedata *can't* be implemented as an absolute cutoff because of the variable DLT and dot11 header lengths.
>
> I'm not sure what else changed between "working" and "not working" for you, but I can't think of any way it could have been hidedata.

I will troubleshoot if the issue arises again, but I won't rule out a faulty wireless sniffer or interference as that may have possibly been why that one scan wasn't detected. If I get further results or have questions , I'll let you know.


Reply to this message


  • Hidedata - laserpad 11:00:24 21/12/2011
    • Hidedata - dragorn 14:43:56 21/12/2011
      • Hidedata - laserpad 08:43:47 22/12/2011