Kismet Wireless

Kismet Forums

 

Posted by:dragorn
Subject:Problem compiling plugin-ptw on BT5R1
Date:18:07:18 03/10/2011

> Hi,
>
> I just grabbed the latest source and compiled and installed kismet into /opt on BackTrack 5 R1 so that I could compile plugin-ptw and use it as I do in BT4. However, when I "make" from the plugin-ptw directory or "make plugins" from the kismet source directory, I get the following:
>
> PLUGIN: plugin-ptw/
> make[1]: Entering directory `/usr/src/kismet/plugin-ptw'
> g++ -I/usr/include/ncurses -I/usr/include -I/usr/src/kismet -g -fPIC -c aircrack-crypto.cc -o aircrack-crypto.o
> In file included from aircrack-crypto.cc:24:
> aircrack-crypto.h:12:26: error: openssl/hmac.h: No such file or directory
>
> I'm not a C guy so I don't really know what to look for. Any ideas?

You need the openssl development headers (maybe openssl-dev, maybe something else, not sure how BT organizes packages).


Reply to this message