Kismet Wireless

Kismet Forums

 

Posted by:dragorn
Subject:who can tell me what is wrong?
Date:13:19:21 22/08/2011

> > configure: error: in `/tmp/p2/libnl-3.1':
> > configure: error:
> > Could not link test program to Python. Maybe the main Python library has been
> > installed in some non-standard library path. If so, pass it to configure,
> > via the LDFLAGS environment variable.
> > Example: ./configure LDFLAGS="-L/usr/non-standard-path/python/lib"
> > ============================================================================
> > ERROR!
> > You probably have to install the development version of the Python package
> > for your distribution. The exact name of this package varies among them.
> > ============================================================================
>
>
> centos5.2 Python-3.2.1 kismet-2011-03-R1 libpcap-1.2.0 libnl-3.1

Your libnl package for some reason requires python, which it didn't list as a dependency. Someone screwed up building your distribution.

Try installing python? I don't know - Kismet doesn't need python for anything, so this is something your libnl packager broke.


Reply to this message