Kismet Wireless

Kismet Forums


Posted by:ClarkCaution
Subject:Using Kismet through BT4 from a VMWare Workstation!
Date:01:58:53 19/05/2011

> Can you screen capture the error message? Basically, you need to tell Kismet what your wireless interface is. Before running Kismet, type iwconfig in a command line and it'll list all your wireless cards. Identify the card you wish to put into promiscuous mode and then jot down the name (RAUSB1 or WLAN0 for example). Now once noted, open up a new command line and type in airmon-ng start [the name of your wireless interface]. So for example you would type in airmon-ng start wlan0. This will then put your card into promiscuous mode. Once done, run Kismet. Kismet should prompt you (unless you've changed the config file) to enter the identity of the wireless interface you wish to use. Enter the one you've just chose (WLAN0 for example) and voila, Kismet should then run!

OKAY. I FOLLOWED YOUR INSTRUCTIONS AND THIS IS WHAT HAPPENED...I apparently started Kismet in promiscuous mode. I went through a process and a box appeared in the middle of the screen outlined in blue. It read Intf, and below that it read Name, and Opts with slots to the right to type in. I typed in "RT2870" in the slot that said intf...because RT2870 is what came up when I typed in airmon-ng. Once I typed in RT2870 next to Intf, I left Name and Opts showed the options of cancel and add below, I tried to select wouldn't allow me...I hit enter...NOTHING HAPPENED. I hit enter again and again...still nothing happened. However, in the background it did read...INFO Kismet server accepted connection from

I don't remember what I clicked but eventually...this message came up

"Couldn't auto-detect driver for interface RT2870. There may be a problem with the device (such as it not existing) or it may use some of the drivers which cannot be auto-detected. See the README section 'Caveats and quirks for specific drivers' to learn how to configure the specific driver.


Reply to this message