Kismet Wireless

Kismet Forums

 

Posted by:totalnoob
Subject:Kismet install help - totalnoob
Date:13:10:29 15/05/2011

> > > Hi Kismet-user,
> > >
> > > I’ve a problem to install Kismet with full functionality. I took this way (http://www.wardriving-forum.de/wiki/Kismet-Newcore) to install Kismet. But I only get the broken Kismet. I can see this in kismet.conf (version-2009 instead of the actual version I downloaded, ncsource instead of source, no suiduser, no ipmap=ip_map and so on).
> >
> > Uninstall the old kismet, first.
> >
> > >
> > > According to Kismet-Documentation, Kismet requires foo-dev or foo-devel before compiling to read all the headers and libraries for full functionality. I thought that this is part of build-essential, but obviously it is not. So I decided to install foo-dev or foo-devel manually by apt-get install foo-dev or foo-devel. But there is no package like that. So I thought that foo-dev or foo-devel is part of a package called foo. But no way. There is even no package foo, foo-dev or foo-devel in the fresh Kismet I downloaded. Even my google search was unsuccessfully.
> > >
> >
> > Foo is a generic term often used, like 'etc'. There are many packages kismet needs to compile, and it changes depending on your system setup. This is indicating that for any given missing package reported during configuration, you'll need both the package, and the whatever-devel package installed.
> >
> > referencing apt implies you have a deb or ubuntu system. For ubuntu, there are packages on the download page, pre-compiled with suid funcitonality. For debian, they MAY work, though they have not been tested.
>
>
> Hi dragorn,
>
> Thanks for Your reply. My message was the short form of what I did. For better understanding I’ve to give You more information. Yes, I use ubuntu and original my intention was to change the kismet version in backtrack 4r2. Therefore I’ve uninstalled kismet by typing
>
> apt-get --purge remove kismet
> # press y
> apt-get clean
>
> Than I took this way to get the kismet-2011-03-R2:
>
> apt-get install build-essential gcc sox libpcap0.8-dev subversion mc libsox-fmt-all libncurses5-dev libnl-dev libnl-doc libwww-perl audacity mplayer festival gpsd
>
> wget http://www.kismetwireless.net/code/kismet-2011-03-R2.tar.gz
> tar xvzf kismet-2011-03-R2.tar.gz
> cd kismet-2011-03-R2/
>
> ./configure
> make dep
> make
> make install
>
> When I fired up kismet I had the old version of kismet, what I could see in kismet.conf. I thought my problem was to remove the old version of kismet in backtrack 4r2.
>
> So I decided to make a fresh ubuntu install (ubuntu 11.04) with an update. In ubuntu there is no kismet installed. So I took the way shown above to get the kismet-2011-03-R2 as root. But no way, I only got the broken version. I repeated the process – every time with a fresh installed and updated ubuntu 11.04 – for the subversion and the ubuntu packages of kismet, downloaded from the kismet site, alternate with make install and make suidinstall. But the result was every time the same – a broken kismet. Because I thought this was a problem of the ubuntu version I repeated the process with ubuntu 10.10, every time fresh installed and updated. But no way to get kismet with full functionality.
>
> I think the problem lies in the following line:
>
> apt-get install build-essential gcc sox libpcap0.8-dev subversion mc libsox-fmt-all libncurses5-dev libnl-dev libnl-doc libwww-perl audacity mplayer festival gpsd
>
> There must be something wrong with that line, so ubuntu cannot read all the headers and libraries needed for a kismet working with full functionality. But what’s the mistake?

Hi dragorn,

a short enlargement to my last post. Meanwhile I’ve found on an ubuntu site – but only tested for ubuntu 8.04 und 9.10 – some other code for the apt-get install line before compiling. The line is apt-get install libncurses5-dev flex libpcap0.8 libpcap0.8-dev libgmp3-dev libmagick9-dev libnl-dev. I added the packages not used before by apt-get install flex libpcap0.8 libgmp3-dev libmagick9-dev. But the result is the same – kismet without full functionality.

When I looked at the compiling output, there was a “no” for the following packages: libnl20, libpcre, sys/capability.h, lcap, sys/pstat.h, libutil.h, setproctitle, luClibc++ and libm.

What packages do I need in the apt-get install line before compiling to get kismet working with full functionality?


Reply to this message