Kismet Wireless

Kismet Forums

 

Posted by:dom123
Subject:Source 'wlan0': channel get ioctl failed 22:Invalid argument
Date:23:35:39 12/05/2011

Hi

I've compiled kismet-drone onto WP543 device - AR7130 CPU and AR9220 wireless chip, 2.6.32.27 kernel and kismet_drone is throwing the following error, though no FATAL messages.

However is not identifying any networks.

I am hoping i'm relatively close to getting this working.. just wondering if someone can help with this final error?

I've tried to provide as much info as possible.

Many thanks.

_____________________________________
kismet-drone - 2010-07-R1-1

ncsource=wlan0:type=ath9k


Error message:
INFO: Source 'wlan0' will attempt to create and use a monitor-only VAP instead
of reconfiguring the main interface
INFO: Created source wlan0 with UUID 663a1fd8-1dd2-11b2-bb06-156103c30632
INFO: Will attempt to reopen on source 'wlan0' if there are errors
INFO: Created TCP listener on port 3501
INFO: Starting GPS components...
INFO: GPS support disabled in kismet.conf
INFO: Kismet drone starting to gather packets
ERROR: Source 'wlan0' doesn't have mac80211 support, disabling VAP creation of
default monitor mode VAP
INFO: Interface 'wlan0' is already marked as being in monitor mode, leaving it
as it is.
ERROR: Source 'wlan0': channel get ioctl failed 22:Invalid argument
INFO: Started source 'wlan0'


/etc/config/wireless

config wifi-device radio0
option type mac80211
option channel 5
option macaddr 00:80:48:6f:7c:a1
option hwmode 11ng
option htmode HT20
list ht_capab SHORT-GI-40
list ht_capab DSSS_CCK-40
# REMOVE THIS LINE TO ENABLE WIFI:
# option disabled 1

config wifi-iface
option device radio0
option network lan
option mode ap
option ssid OpenWrt
option encryption none


Reply to this message