Kismet Wireless

Kismet Forums


Posted by:burnwhenfinished
Subject:General trouble getting Kismet running, v. 2011.01.1
Date:16:10:53 26/03/2011

> > Running 2011.01.1 in Ubuntu 10.10 64 bit on a HP g62-340us.
> >
> > When I run Kismet from the terminal it goes like this:
> >
> > Kismet: Automatically start Kismet server?
> > Me: Yes
> > K:Startup Options, Logging, Log Title, Show Console
> > M: Start
> > K: No Sources. Kismet started with no packet sources defined. No sources were defined or all defined sources encountered unrecoverable errors. Kismet will not be able to capture any data until a capture interface is added. Add a source now?
> > M: Yes
> > K: Add source. Intf, Name, Opts (no idea what to put for any of this.)
> Interface is the interface you plan to capture from.

That being "wlan0" with the name and opts listed on the kismet.conf file? If kismet figures this on its own why then ask every time kismet is run?

> > M: Cancel
> > K: (from the Console Window) FATAL: !!! CRITICAL ERROR !!! - Could not launch Kismet_capture control binary, due to permission errors. To run Kismet suid-root your user MUST BE IN THE "kismet' GROUP. Use the 'groups' command to show groups your user is in, and consult the Kismet README for more information. - Kismet will not operate correctly.
> > M: Close Console Window
> >
> You didn't install it suidroot, or you're not in the kismet group, or something in your distribution killed the suid bit on it.

I uninstalled kismet through the ubuntu software center. then installed with "sudo dpkg -i kismet-2011.01.1.amd64.deb" this gave me:
"dpkg: dependency problems prevent configuration of kismet:
kismet depends on libcap2-bin; however:
Package libcap2-bin is not installed.
kismet depends on libnl2; however:
Package libnl2 is not installed."
installed libcap2-bin and libnl2 through synaptic.
that got things going. entered the interface information listed on kismet.conf file.


> >
> > Have looked at the kismet.conf file. Seems as though that file has a more minimal role in the newer versions of Kismet. Anyway this is what shows up concerning the source:
> >
> > Any help or suggestions would be appreciated. Install files acquired from Installed 64 bit version through Ubuntu Software Center. Was asked about user at one point. entered my user name.
> >
> If you installed it suid-exec it should have the suid bit on it. Seems like some versions of ubuntu may strip it off during install for no apparent reason (none that I've been able to recreate myself, anyhow). Make sure it's owned by group kismet, is +S on the file for suid, and is only executeable by root and the group. Make sure your user is in the kismet group. Make sure it really thinks you're in the group by running 'groups' in a terminal and confirming you're in the group.

as long as I run "sudo kismet" it works. I then installed the plugins and loaded them. Now all the networks that were listed prior are gone. I installed plugins as "sudo dpkg -i kismet-2011.01.1.plugins-restricted.amd64.deb" no errors. I see network names until I load plugins, then no names just limited packets in the packet graph. do these plugins work with these programs running in additional terminals?

Reply to this message