Kismet Wireless

Kismet Forums

 

Posted by:dragorn
Subject:General trouble getting Kismet running, v. 2011.01.1
Date:15:53:45 25/03/2011

> Running 2011.01.1 in Ubuntu 10.10 64 bit on a HP g62-340us.
>
> When I run Kismet from the terminal it goes like this:
>
> Kismet: Automatically start Kismet server?
> Me: Yes
> K:Startup Options, Logging, Log Title, Show Console
> M: Start
> K: No Sources. Kismet started with no packet sources defined. No sources were defined or all defined sources encountered unrecoverable errors. Kismet will not be able to capture any data until a capture interface is added. Add a source now?
> M: Yes
> K: Add source. Intf, Name, Opts (no idea what to put for any of this.)

Interface is the interface you plan to capture from.

> M: Cancel
> K: (from the Console Window) FATAL: !!! CRITICAL ERROR !!! - Could not launch Kismet_capture control binary, due to permission errors. To run Kismet suid-root your user MUST BE IN THE "kismet' GROUP. Use the 'groups' command to show groups your user is in, and consult the Kismet README for more information. - Kismet will not operate correctly.
> M: Close Console Window
>

You didn't install it suidroot, or you're not in the kismet group, or something in your distribution killed the suid bit on it.

> I have tried to look at the kismet_capture file in /usr/bin. it is listed as an executable. When I try to open it with gedit I get "Could not open file /usr/bin/kismet_capture" followed by "gedit has not been able to detect the character encoding. Please check that you are not trying to open a binary file. Select a character encoding from the menu and try again." Tried both listed character encodings. Nothing.

It's a binary. You're not going to be able to read it in any intelligent fashion with a text editor.

>
> Have looked at the kismet.conf file. Seems as though that file has a more minimal role in the newer versions of Kismet. Anyway this is what shows up concerning the source:
>

> Any help or suggestions would be appreciated. Install files acquired from https://www.kismetwireless.net/download.shtml. Installed 64 bit version through Ubuntu Software Center. Was asked about user at one point. entered my user name.
>

If you installed it suid-exec it should have the suid bit on it. Seems like some versions of ubuntu may strip it off during install for no apparent reason (none that I've been able to recreate myself, anyhow). Make sure it's owned by group kismet, is +S on the file for suid, and is only executeable by root and the group. Make sure your user is in the kismet group. Make sure it really thinks you're in the group by running 'groups' in a terminal and confirming you're in the group.

> Rob


Reply to this message