Kismet Wireless

Kismet Forums

 

Posted by:Fafnir
Subject:Kismet-2011-01-R1: suidroot not working with .deb?
Date:20:34:56 05/03/2011

Hi guys,

first of all: thanks to dev-team for this great piece of software *thumbs up* :).

I installed newest Kismet using the official 32bit .deb-file, with "sudo dpkg -i kismet-2011.01.1.i386.deb". My OS is Kubuntu 10.10 x32. It worked fine so far, Kismet asked me, if I want to use suidroot, where I've agreed with <Yes>. Second I had to enter my username to add myself to the kismet group.

Everything worked just fine, but when I try to start kismet via terminal with "kismet", it says following:

---
[SERVER] ERROR: IPC child Source 'eth1' requires root permissions to shut down, but
[SERVER] we're not running as root. Something is wrong.
---

But when I ran kismet with "sudo kismet", it finally works. Without sudo, kismet isn't able to receive any networks.

Here some more info for you:

---
michael@TravelMate:~$ ls -l /usr/bin/kismet*
-rwxr-xr-x 1 root root 261 2011-01-04 12:38 /usr/bin/kismet
-rwxr-xr-- 1 root kismet 617224 2011-01-04 12:38 /usr/bin/kismet_capture
-rwxr-xr-x 1 root root 1479172 2011-01-04 12:38 /usr/bin/kismet_client
-rwxr-xr-x 1 root root 716724 2011-01-04 12:38 /usr/bin/kismet_drone
-rwxr-xr-x 1 root root 1381828 2011-01-04 12:38 /usr/bin/kismet_server
---
michael@TravelMate:~$ getent group kismet
kismet:x:126:michael
---
michael@TravelMate:~$ groups michael
michael : michael adm dialout cdrom plugdev lpadmin admin sambashare vboxusers kismet
---

Well, then I removed kismet, and compiled it from source with "make suidinstall". THEN it works just perfect.

Any ideas, what's going wrong here? Why does suidroot not work, when I install it via the official .deb?

Many thanks in advance for any help.

Kind regards,
Fafnir


Reply to this message