Kismet Wireless

Kismet Forums

 

Posted by:w1ck3d64
Subject:failed to enable TCP listener for the Kismet UI server [Ubuntu 10]
Date:20:49:56 12/02/2011

Hi all,

I've downloaded the latest release of Kismet (64-bit) and am running it on Ubuntu 10.

I've set up the kismet.conf files and ran make and make install etc etc etc..set suids...etc etc

now I have a problem with starting the kismet UI server..

i keep getting the error: FATAL: Failed to enable TCP listener for the Kismet UI server

I have no idea what is happening...here is my kismet.conf part for the ncsource and also the TCP part:

=================================


# See the README for full information on the new source format
# ncsource=interface:options
# for example:
# ncsource=wlan0
# ncsource=wifi0:type=madwifi
# ncsource=wlan0:name=intel,hop=false,channel=11
ncsource=wlan0

...
...

# Client/server listen config
# listen=tcp://127.0.0.1:2501
listen=tcp://0.0.0.0:2501

# People allowed to connect, comma seperated IP addresses or network/mask
# blocks. Netmasks can be expressed as dotted quad (/255.255.255.0) or as
# numbers (/24)

allowedhosts=127.0.0.1

# Maximum number of concurrent GUI's
maxclients=5
# Maximum backlog before we start throwing out or killing clients. The
# bigger this number, the more memory and the more power it will use.
maxbacklog=5000

# Port to serve GUI data
tcpport=2501
# this host, reverts to INADDR_ANY if specified incorrectly.
bindaddress-127.0.0.1

==========================

i changed the listen to listen=tcp://0.0.0.0:2501 as it listens for everything as stated in the documentation...

yet I can't start the server...any ideas?

thanks all!


Reply to this message