Kismet Wireless

Kismet Forums

 

Posted by:bayeagle
Subject:No channel hopping with ipw2200
Date:21:24:49 09/02/2011

> > > > Your drivers are old and report most of mac80211 but don't accept the standard netlink commands to control channel.
> > > >
> > > > There's unfortunately no good way to fix this right now - make sure you're running the latest drivers and hope that fixes it, an option will have to be added to kismet to override the mac80211 detection and use the deprecated channel controls on those drivers.
> > >
> > > Many thanks for the swift reply - that saves further hours of clueless experiments.
> >
> > Should be fixed in the latest svn (though I haven't had an opportunity to test it since I don't have the card).
> >
> > ipw2100 and 2200 will disable mac80211 functionality - it won't make a vap (no idea if it could anyhow) and it'll use the old channel control code.
>
> Amazing, works like a breeze!
>
> "ERROR: Detected 'ipw2200' or 'ipw2100' for interface eth1; This driver
> will not change channel using mac80211 commands in most cases.
> Kismet will use legacy channel control commands."
> ... and no further setchannel() errors.
>
> Many thanks for your quick help, greatly appreciated.
> - Johannes

I'm having the same exact issue with ipw2200 (dell 600m) on a brand-new Ubuntu 10.10 build with a clean install of Kismet-2011-01-R1 that I just compiled.

Really not sure which way to go.....


Reply to this message