Kismet Wireless

Kismet Forums

 

Posted by:00
Subject:Menu hotkey on international keyboard
Date:21:31:29 05/11/2010

Guys what the hell is wrong with the key combinations in the new kismet (2010-07-R1). The menus only work by clicking on them with the mouse in X.

Tried all CTRL+ALT+SHIFT + old key combos, ESC+key combo nothing is working :(

> > What keys are similarly useful on international keyboards? '`' will also work, by the way, if that is more easily reached. On the US kb ~ and ` are the same physical key.
>
> The '`' is both hard to reach and requires a combination too. On my keyboard (norwegian layout) | and § share the same key. This is the key directly below ESC which translates to ~ on a us keyboard, I guess. Looks like both § and | are often single key presses on many keyboards, maybe that is an option? How about an option for using the "windows"-keys? Those are available on most keyboards nowadays and great for shortcuts.
>
> >
> > Escape is probably not working as part of the problem with compensating for broken ncurses which report multi-char escape handling and then don't do it. I can add a timer to handle that, at least.
>
> Thanks, that helps.
>
> >
> > It may be possible to make it a configurable option, I'll have to look into how to best prompt for it. Is there any sort of environment variable set for intl keyboards that Kismet could detect?
> >
> > I know very little about intl keyboard handling, as you can tell.
>
> I do not now enough about intl keyboard handling either. I suppose you would have to detect the keymap if it is a console and probably do it differently in X. Hopefully there is a standardized way, at least in Linux.


Reply to this message