Kismet Wireless

Kismet Forums

 

Posted by:bobmagoo
Subject:launch problem
Date:15:35:13 06/10/2010

Go with compiling from source for Ubuntu Lucid, the package they have is only up to the version of Kismet from May of 2008(http://packages.ubuntu.com/lucid/kismet).

I've been running the latest release(Kismet-2010-07-R1) for a bit now and it works great.

After you compiled(I had to install a few -dev packages like lipcap-dev and libncurses-dev when ./configure wouldn't continue without them) and get things installed, you should be fine just running kismet, if it doesn't detect the card, add a line to /usr/local/etc/kismet.conf with something like "ncsources=wlan0:type=BCM4315" to prod kismet into detecting the right card/driver.

Like I said, it's been working great for me after the above steps.
Great program, newcore is good times.

> > Hi . I install kismet on Ubuntu 10.04 with Synaptic , and change kismet.conf, but i cannot start kismet
> >
> > Launching kismet_server: //usr/bin/kismet_server
> > Suid priv-dropping disabled. This may not be secure.
> > No specific sources given to be enabled, all will be enabled.
> > Non-RFMon VAPs will be destroyed on multi-vap interfaces (ie, madwifi-ng)
> > Enabling channel hopping.
> > Enabling channel splitting.
> > FATAL: Unknown capture source type 'BCM4315' in source 'BCM4315,eth1,broadcom'
>
> this looks like you're running a very old version of kismet. If you insist on using a version years out of date, it may not support your cards, and bcm4315 isn't one I remember ever being supported in a kismet version that old.
>
> The release version is 2010-07-R1, you should use that. If your distribution does not provide an up-to-date version of the package you should complain to them, and will have to compile it manually yourself.


Reply to this message