Kismet Wireless

Kismet Forums

 

Posted by:ilf
Subject:2010-07-R1: configure menu escape
Date:09:35:02 06/10/2010

README sais:

The menu is activated with 'escape', '`' or '~'.

Running the kismet_client sais:

Press '`' or '~' to activate menus.

kis_panel_widgets.cc sais on :1398-1399:

// Activate menu
if (in_key == '~' || in_key == '`' || in_key == 0x1B) {

Why does 'escape' not show up when running the client?
Also, 'escape' doesn't work for me. No matter what I try. Any idea?

Secondly, both '`' and '~' really suck on a non-US keyboard layout.
So I patched kis_panel_widgets.cc to also allow '^':

// Activate menu
- if (in_key == '~' || in_key == '`' || in_key == 0x1B) {
+ if (in_key == '~' || in_key == '`' || in_key == '^' || in_key == 0x1B) {
if (cur_menu < 0) {

Maybe this could be an option in kismet_ui.conf for easier configuration?


Reply to this message