Kismet Wireless

Kismet Forums


Posted by:cutter409
Subject:ath9k w/ kismet
Date:14:35:08 31/08/2010

> Hey cutter,
> Sounds like you have a very similar setup to what I am currently using at the moment. I too, am using ath9k driver on OpenWRT and have the same issue with both corrupted beacon frames, and the channel get error.
> My wireless card is a Mikrotik R52N in a RouterStation Pro.
> Was thinking of opening a ticket somewhere, but so far thought it was a problem with my OpenWRT build. Now that I know other people are having a similar error I might open a ticket at linux wireless, or ath9k message board and try find a solution to the corrupt beacon frame issue.
> As far as the channel get error, I am still able to hop using the Mikrotik. Unsure what the error is actually causing.
> If you want Kismet to make a VAP off the monitor mode interface use the following line in source code:
> ncsource=wlan0:type=mac80211,hop=true,forcevap=true
> The "forcevap=true" is the important part, that forces a VAP to be made. Thats the method I use, so that you are not capturing packets from the wireless interface in AP or STA mode. I set the inerface to be in monitor mode in /etc/config/wireless.

Thanks for the reply, but I've actually tried that. I still don't get any packets.

Kismet says:

INFO: Source 'wlan0' attempting to create mac80211 VAP 'wlan0mon'
ERROR: Source 'wlan0': channel get ioctl failed 22:Invalid argument
INFO: Started source 'wlan0'

And then nothing is detected. Are you using the same /etc/config/wireless settings as I am (monitor mode)?

My theory is that Kismet "works" in station mode because the card is hopping trying to associate with the given access point, and because Kismet isn't controlling the hopping, that might cause the corrupt frames. When the card is configured in monitor mode, it doesn't hop at all.

Or I could be totally wrong, because when I try to manually set the channel "iw phy0 set channel 11" kismet still doesn't pick up anything.

Reply to this message