Kismet Wireless

Kismet Forums

 

Posted by:cutter409
Subject:ath9k w/ kismet
Date:23:44:24 30/08/2010

> Hello,
>
> I'm having some difficulty getting kismet to work with an ath9k card on OpenWRT using 2010-07-R1.
>
> In my kismet.conf, I'm simply using "ncsource=wlan0".
>
> My /etc/config/wireless is:
> --------------
> config wifi-device radio0
> option type mac80211
> option macaddr 00:15:6d:84:66:2a
> option diversity 0
> option rxantenna 1
> option txantenna 1
>
> config wifi-iface
> option device radio0
> option mode monitor
> --------------
>
> That gives me a monitor mode interface:
> --------------
> wlan0 IEEE 802.11abgn Mode:Monitor Tx-Power=0 dBm
> RTS thr:off Fragment thr:off
> Power Management:off
> --------------
>
>
> This is what kismet_server gives me:
> --------------
> INFO: Matched source type 'ath9k' for auto-type source 'wlan0'
> INFO: Using hardware channel list 1:3,2,3,4,5,6:3,7,8,9,10,11:3,36,40,44,48
> ,52,56,60,64,5500,5520,5540,5560,5580,5660,5680,5700,149,153,157,161,
> 165, 32 channels on source wlan0
> INFO: Source 'wlan0' will attempt to create and use a monitor-only VAP
> instead of reconfiguring the main interface
> INFO: Created source wlan0 with UUID 1effe8ca-b48e-11df-b4c2-156103c30632
> INFO: Will attempt to reopen on source 'wlan0' if there are errors
> INFO: Created TCP listener on port 2501
> INFO: Kismet drone framework disabled, drone will not be activated.
> INFO: Inserting basic packet dissectors...
> INFO: Allowing Kismet frontends to view WEP keys
> INFO: Starting GPS components...
> INFO: GPS support disabled in kismet.conf
> INFO: Creating network tracker...
> INFO: Creating channel tracker...
> INFO: Registering dumpfiles...
> INFO: Pcap log in PPI format
> INFO: Kismet starting to gather packets
> ERROR: Not creating a VAP for wlan0 even though one was requested, since
> the interface is already in monitor mode. Perhaps an existing
> monitor mode VAP was specified. To override this and create a new
> monitor mode vap no matter what, use the forcevap=true source option
> ERROR: Source 'wlan0': channel get ioctl failed 22:Invalid argument
> INFO: Started source 'wlan0'
> -------------
>
>
> Here's the strange thing. If I change /etc/config/wireless so that the Mode is "sta" (station), and give it an ssid, kismet actually creates works, but I detect my own probe requests even with txpower set to zero. I still get that invalid argument error though..
> -------------
> INFO: Kismet starting to gather packets
> INFO: Source 'wlan0' attempting to create mac80211 VAP 'wlan0mon'
> ERROR: Source 'wlan0': channel get ioctl failed 22:Invalid argument
> INFO: Started source 'wlan0'
> INFO: Detected new probe network "test_ap", BSSID 00:15:6D:84:66:2A,
> encryption no, channel 0, 54.00 mbit
> -------------
>
> Any insight?


Also, I'm getting a lot of corrupt packets when I do get it to work like this.

INFO: Detected new managed network "amer\017`u_Uhfi", BSSID 6C:7F:74:C2:D2:EC, encryption yes, channel 0, 54.00 mbit
INFO: Detected new managed network "americu_\304hfi", BSSID 68:7F:F4:8A:D2:EC, encryption yes, channel 0, 54.00 mbit

Those should both be the same access point.


Reply to this message