Kismet Wireless

Kismet Forums

 

Posted by:hardbop
Subject:Kismet under Windows - Packet dumps not being saved. (Solution!)
Date:23:53:11 06/08/2010

Just an update on this in case others have not found a way to their own solution.

There seems to be a "bug" in the KismetRunner.exe launcher that forces it to use the "-n" (no logging whatsoever) switch when launching the kismet_server.exe program every time.

I stepped through KismetRunner.exe with a debugger and it doesn't even read the "EnableLogging" option in the "KismetConf.cfg" file which is created by the GUI frontend. Instead it uses its own hardcoded arguments to launch the kismet server and among those arguments is the "-n" to disable all logging.

So to fix this, I simply used a hex editor on the KismetRunner.exe binary to modify the string which contained the arguments. I replaced the "-n" with blank spaces and now log files are being created and written to.

For those wanting to duplicate this fix, follow these simple steps.

1. Open the file "KismetRunner.exe" with a hex editor.
2. Jump to the offset 0xA32B (41771 in decimal).
3. Replace the bytes "2D 6E" WITH "20 20".
4. Save the file!

Remember to back up KismetRunner.exe before using the hex editor in case you make a mistake.

Also note that this fix is specific to Windows Kismet - 2009-06-R1. It may not work on older or newer versions due to the fact that the KismetRunner executable may be different (however, the general procedure should be the same -- find the argument string in the binary and patch it).

Good luck!


Reply to this message