Kismet Wireless

Kismet Forums


Posted by:stomponthis
Subject:2010-07 Drone Test - Still connection issue
Date:22:39:49 01/08/2010

> I have the exact same issue.
> I am using a Ubiquiti Nanostation M and get the same error as you regarding mac80211. When I try to connect to the drone it says "fd 3 read error, ring buffer full" a bunch of times.
> I just installed kismet from opkg but not sure which version I have as I am very new to linux.

Pretty sure that the Kismet opkg package provided in the OpenWRT repositories is not compiled to allow mac80211 VAP creation support. To get mac80211 support I had to compile OpenWRT myself with a newer Kismet version. Guessing that the wireless chipset in the Nanostation M is using mac80211? You only need mac80211 if you are using a newer wireless driver, eg. ath9k.
If you are using a stable version of OpenWRT (eg. Backfire) you are most likely using Kimset 2009-06-R2. To find out use the following command:

opkg list-installed | grep kismet

As far as the error message, I have no idea sorry. Dragorn would know a lot more about that stuff! As he said, when connecting to a Kismet drone ensure the following criteria are met:

Firewall - allow traffic through from the Kismet drone. I just turn it off for testing (/etc/init.d/firewall stop)(/etc/init.d/firewall disable)
Routing - check drone to server connection (I use ping to check)
Kismet configs - make sure allowed connections in kismet_drone.conf are defined and kismet.conf has drone settings.

A good way to troubleshoot is to install all the kismet packages (kismet drone, server and client) on OpenWRT and check it is running properly. Note: in this scenario use the drone to collect traffic and forward to the local kismet server on OpenWRT. The kismet.conf file should have drone source as on the local interface.

Hope some of that rambling helps! I have had major issues setting up my Kismet drone, but it is all about learning! =D

Reply to this message