Kismet Wireless

Kismet Forums

 

Posted by:stomponthis
Subject:Kismet server cannot connect to drone
Date:07:23:49 23/07/2010

So after all of the things I have tried I am still having issues with my kismet drone.

Kismet Server produces the following error:

Could not create connection to Kismet drone server at 192.168.1.6:3501 (Operation now in progress), will attempt to reconnect in 5 seconds.

I know I have my config files fine (add drone source on kismet.conf on server, add drone source and allowed hosts on kismetdrone.conf). I am sure these are right. To make sure, I installed the latest kismet drone package from OpenWRT repositories (now 2010-01 is available from devel source) and used exactly the same configs and settings, and was able to connect to the drone and capture packets.
I would just use the OpenWRT package for my testing but it is not compiled with mac80211 support. I know mac80211 and the ath9k driver are now functioning fine on my wireless router, but the kismet drone application cannot create a new monitor mode interface from the existing interface.
By the way, I am now using Kismet 2010-07-R1 as it has fixed drone issues. Using 2010-07-R1 on both the drone, and machine running kismet server and client. But have also tried different versions of the Kismet devel source (3028 and 3041). All are giving me the same issue of the server not being able to connect to the drone. No other errors are being produced when either the drone or server are started.

As usual have saved all compiling output and configs if that would help anyone help me!


Reply to this message