Kismet Wireless

Kismet Forums

 

Posted by:HKAirpost
Subject:Disable JSON connection to gpsd
Date:17:35:07 14/06/2010

> > Hello, I'm using Kismet-2010-01-R1. Is there an undocumented option so it connects to gpsd without using JSON?
>
> No, because GPSD is removing non-json and will only be able to communicate that way.
>
> -m

OK let me explain my issue with further details then:

1.-I used an older version of kismet along with a 2.90 version of GPSD on an openwrt router. GPSXML and NETXML log used to be generated but pykismetkml could not handle their output.

2.- I updated kismet to the latest version. It detects signals fine as long as I don't ask it to connect to the same GPSD version that used to work.

3.- I updated GPSD to version 2.93 but i face the same issue. Kismet hangs there and report nothing more than this:


INFO: Kismet starting to gather packets
INFO: Madwifi source wifi0 created monitor-mode VAP wifi0::kis0.
ERROR: Source 'kis0' doesn't have mac80211 support, disabling VAP
creation
of default monitor mode VAP
INFO: Interface 'kis0' is already marked as being in monitor mode,
leaving
it as it is.
INFO: Started source 'wifi0'
INFO: Connected to a JSON-enabled GPSD version 2.93, turning on JSON
mode
INFO: Detected new managed network "Holly", BSSID 00:13:21:16:AC:06,
encryption yes, channel 1, 54.00 mbit

.gpsxml logs stays empty and i can't find any crash reported.
I tried to connect to GPSD with xgps it works fine.

Any idea of what might prevent kismet_server to connect to GPSD correctly?
Any log worth checking?

Regards


Reply to this message