Kismet Wireless

Kismet Forums

 

Posted by:guichebarou
Subject:compile problems
Date:19:29:07 18/05/2010

> > Hey,
> >
> > I'm kind of new to Linux, and I am having problems compiling kismet. When I run 'make' I get the error that says:
> >
> > guichebarou@ubuntu:~/Desktop/kismet-2010-01-R1$ make
> > make: *** No targets specified and no makefile found. Stop.
> >
> > What am I doing wrong? Does this mean that my ./configure didn't execute properly?
> >
>
> Probably. Pay attention to the output of configure, it's fairly important.


So does that mean that the configure file is responsible for generating the makefile? That seems rather odd to me. I would think that the makefile would be native to the .tar.gz. Here is a list of the things that returned 'no' from the checks when I ran ./configure:

checking for g++... no
checking for c++... no
checking for gpp... no
checking for aCC... no
checking for CC... no
checking for cxx... no
checking for cc++... no
checking for cl.exe... no
checking for FCC... no
checking for KCC... no
checking for RCC... no
checking for xlC_r... no
checking for xlC... no
checking whether we are using the GNU C++ compiler... no
checking whether g++ accepts -g... no

...

checking whether stat accepts an empty string... no

...

checking for accept() addrlen type... socklen_t
checking for special C compiler options needed for large files... no
checking for _FILE_OFFSET_BITS value needed for large files... no

...

checking for libm math function in std libs... no
checking for pow in -lm... yes
checking for main in -luClibc++... no
checking for main in -lstdc++... no
configure: error: Neither uclibc uClibc++ or standard gcc stdc++ libraries found.

I don't see anything that looks like it is related to the makefile, but maybe I'm wrong.

In the directory in which I un-tar'd the kismet folder, I have two files called Makefile.in and Makefile.inc.in. I thought that these were the files with which I need be concerned but apparently not. What should I try next? Thanks in advance.


Reply to this message