Kismet Wireless

Kismet Forums

 

Posted by:rjb1290
Subject:Compiling problems :(
Date:23:41:24 05/05/2010

> > > That's also very weird. Maybe your $TERM variable is being messed up. It ought to work out-of-the-box on OSX terminal. Try setting TERM to xterm or something, or maybe your ncurses terminal definitions are screwed up. It's not interpreting escape codes properly.
> >
> >
> > Well, here's some more fun. I was sick of it so I just formatted my disk (needed to anyway) and reinstalled OS x, then xcode and a couple other things, and tried again. Configuring/compiling/installing was a breeze, but the arrow key issues are still there.
> >
> > All I did after installing was copy some files, software update, and install microsoft office, ilife, and itunes. Any idea what could be breaking it?
>
> What terminal are you trying to use?
>
> I just built the latest Kismet on snow leopard and using apples default terminal app everything works just fine - $TERM is set to xterm-color by default.
>
> -m

The default terminal...literally all I do is open terminal and "sudo kismet". $TERM is set to xterm-color.

This is so weird. I don't know why computers hate me so much. I think I'm going to format again (might as well, since I haven't reinstalled everything yet), update to 10.6.3 or whatever it is now, install xcode, then try it...then I'll try installing everything else to find out what's breaking it. I'm using an office 2011 beta, so who knows, maybe that's screwing it up. Or maybe my computer's haunted. I guess I'll know in a couple hours.


Reply to this message