Kismet Wireless

Kismet Forums


Posted by:rjb1290
Subject:Compiling problems :(
Date:06:08:15 05/05/2010

> > Ah—you were right, I reinstalled xcode and it worked.
> >
> > Now, new problem: I can't use the arrow keys to navigate. If I hit any arrow key when typing (for example, in the "startup options" field when starting a server) it types "0A" "0B "0C" or "0D" (depending on which one I hit). That isn't really a problem, but I can't navigate within the program. If I'm looking at the networks it's found and hit an arrow key, it just highlights/unhighlights "kismet" in the menu at the top.
> >
> > Any suggestions? Hahah although I can't actually USE kismet yet, it sure looks like it's working very nicely.
> >
> That's also very weird. Maybe your $TERM variable is being messed up. It ought to work out-of-the-box on OSX terminal. Try setting TERM to xterm or something, or maybe your ncurses terminal definitions are screwed up. It's not interpreting escape codes properly.

Well, here's some more fun. I was sick of it so I just formatted my disk (needed to anyway) and reinstalled OS x, then xcode and a couple other things, and tried again. Configuring/compiling/installing was a breeze, but the arrow key issues are still there.

All I did after installing was copy some files, software update, and install microsoft office, ilife, and itunes. Any idea what could be breaking it?

Reply to this message