Kismet Wireless

Kismet Forums

 

Posted by:topi
Subject:FATAL: channel get ioctl failed 22:Invalid argument
Date:04:46:19 09/04/2010

Forget it, the problem was solve upgrading to the last version of kismet

Thanks and Regards

> Hi, I have the follow problem with kismet 2008.05.R1 and my wireless card "Intel Corporation PRO/Wireless 4965 AG or AGN [Kedron] Network Connection (rev 61)". I am using iwlagn driver:
>
> # lsmod | grep iwl
> iwlagn 62199 0
> iwlcore 67306 1 iwlagn
> mac80211 121381 2 iwlagn,iwlcore
> cfg80211 86910 3 iwlagn,iwlcore,mac80211
> led_class 1757 2 iwlcore,thinkpad_acpi
>
> When I try to start kismet I get:
>
> # kismet
> Launching kismet_server: //usr/bin/kismet_server
> Suid priv-dropping disabled. This may not be secure.
> No specific sources given to be enabled, all will be enabled.
> Non-RFMon VAPs will be destroyed on multi-vap interfaces (ie, madwifi-ng)
> Enabling channel hopping.
> Enabling channel splitting.
> NOTICE: Disabling channel hopping, no enabled sources are able to change channel.
> Source 0 (intel): Enabling monitor mode for iwl3945 source interface wlan0 channel 6...
> FATAL: channel get ioctl failed 22:Invalid argument
> Done.
>
> I tried to edit kismet.conf, I have tried with the following options:
>
> source=iwl3945,wlan0,intel
> source=iwlagn,wlan0,intel
>
> Also, I tried putting manually wlan0 in monitor mode, but the result is the same.
>
> Please, if you have some suggests.......
>
> Thanks and Regards


Reply to this message