Kismet Wireless

Kismet Forums

 

Posted by:sfeil
Subject:2.6.30 kernel not working with Kismet --SOLVED--
Date:18:43:55 24/01/2010

When I upgraded from kernel 2.6.22.6 to kernel 2.6.30-gentoo-r8 I found out that I could no longer use Kismet with my zd1211 based USB wifi device. I even changed the "/usr/src/linux" link to point to the new source and recompiling Kismet.

With the new kernel I can connect to the Internet and use commands like "iwlist eth2 scan". But, when I try to run Kismet I get the following error.

FATAL: Failed to retrieve list of private ioctls 95:Operation not supported

When I configured the kernel I uses the script to update the kernel config file, then I tweaked the configuration with "make gconfig". As far As I remember I did not change the zd1211 parameters.

"zcat /proc/config.gz | grep -i zd1211" yields

CONFIG_ZD1211RW=m
# CONFIG_ZD1211RW_DEBUG is not set

Does anyone have an idea that I can try?

--SOLVED--
With kernel 2.6.22.6 both

source=zd1211,wlan0,zd1211rw and
source=hostap,wlan0,zd1211rw

worked. However with 2.6.30 only

source=zd1211,wlan0,zd1211rw

works. I started using kismet with an early 2.6 kernel when only hostap was avalible so I had been coppying my /etc/kismet.conf file.


Reply to this message