Kismet Wireless

Kismet Forums


Posted by:andre
Subject:Kismet-2009-11-R1 on the N900
Date:17:37:31 31/12/2009

> > I've never seen a N900 in person, let alone had one to play with, so don't have any real suggestions.
> >
> > If it's anything like the 8xx series, gpsd is already built in, and it probably won't play along with running it independently.
> >
> > Kismet doesn't bind to the device, so bind problems you have there have to be something to do with the n900 software itself. Maybe dmesg or syslog will tell you more there. Kismet CANNOT establish or shut down the rfcomm connection, so you'll have to look at the system level.
> >
> > -m
> >
> > > hi,
> > > i'm trying to port kismet and gpsd to the n900. both compiled well and are working for their own, but as soon as i start the kismet_server the gpsd device paired to the n900 loses his connection.
> > >
> > > There is a blue light on the gps receiver (a navilink bt-359 -they are sold under a diffent vendor name in the states) that indicates the bluetooth status on the device i.e. slow blinking for no connection and faster blinking for an established one.
> > >
> > > normally, i use a little shellscipt to pair the device and start kismet:
> > >
> > > "rfcomm bind /dev/rfcomm0 00:de:ad:be:ef:00 && sleep 15 & gpsd /dev/rfcomm0 & kismet" (this works for me on the nokia 770)
> > >
> > > when the kismet-server gets started, the blue light flashes for 2-3 seconds (way longer than normal), then stops blinking for 4-5 seconds (also way longer than normal) and then it indicates no connection. if i try to start gpsd with the -b switch for a read only connection, it only stops blinking for 4-5 seconds, but also loses the rfcomm connection. gpsd runs fine but lost the connection to the device-link. i checked this with a telnet connection to the gpsd. I've also tried to fiddle around in the kismet.conf i.e. changing the "gpsmodelock" and "gpsreconnect" values, but nothing solved the problem.
> > >
> > >
> > >
> > > This is reproducable with different versions of kismet and gpsd:
> > >
> > > kismet-2009-11-r1
> > > kismet-2009-06-r1
> > > gpsd-2.90
> > > gpsd-2.39
> > >
> > > any idea how to fix this?
> > >
> > > greetings from germany
> > > andrè
> Hi andrè
> How did you compile it ? Direct on the N900 ? I am trying that to, but i get stuck ... Please help.

you can't compile directly on the n900 so you'll need a crosscompiling enviroment.
if you already have a debian, ubuntu or fedora system running you just need to download the python-installer-script an execute it as root.
Otherwise you'll need a vm or install scratchbox and the maemo-sdk manually in the distro of your choice. For more info look here: and here:

I wasn't been able to get any gps related programs from the repositories to work (aircrack, maemo-mapper, ovi-maps-demo). Not even the nokia ovi-maps-demo that comes with the n900 worked with the internal a-gps and my gps bluetooth mouse. Also, there are no gps related entries in the dmesg and the syslog.
There are already some people in the maemo community trying to get gpsd to work:

These are the notes i've taken during the installation and usage of the sdk. I hope they help.
My kismet deb for the n900 is here:

Get the Maemo5-SDK installer from here:

Get the stuff you need and install.


Starting scratchbox:

Disable VSDO support in the kernel
# echo 0 | sudo tee /proc/sys/vm/vdso_enabled

1. Start the Xephyr xserver.
$ Xephyr :2 -host-cursor -screen 800x480x16 -dpi 96 -ac -kb &

2. Log out and log back in or execute the following command to run scratchbox in the current terminal session.
$ newgrp sbox

3. Login to scratchbox and start the SDK on X86 target.
$ /scratchbox/login

Welcome to Scratchbox, the cross-compilation toolkit!
Use 'sb-menu' to change your compilation target.
See /scratchbox/doc/ for documentation.
[sbox-FREMANTLE_X86: ~] > export DISPLAY=:2
[sbox-FREMANTLE_X86: ~] > start

4. Type in "sb-menu" and set up scratchbox. Don't forget to set the target to FREMANTLE_ARMEL. The rootstrap should be in your home dir inside the scratchbox.


to build your own .debs its best to make an extra directory in your user-dir i.e. "sources" and
add extra dirs for the software you want to compile and package.

To get the source from the Nokia sdk repositories just type:
"apt-get source <packagename>".

To build the package go to the sourcedir and type "dpkg-buildpackage -rfakeroot -d -b"

If you are using Tarballs from the net just decompress them, go to the sourcedir and type "dh_make ../<nameofpackage.tar.gz>".
Follow the instructions and then use the "dpkg_buildpackage -rfakeroot -d -b" command again to build the

If you run into compiling problems look for an already existing debian dir in the sources and delete it.


greets and a happy new year!

Reply to this message