Kismet Wireless

Kismet Forums

 

Posted by:cybrsnpr
Subject:Kismet-Newcore Multiple Sources
Date:23:33:23 30/12/2009

I'm working with kismet-newcore and have run into a problem which I can't find a solution for.

I'm trying to use multiple sources (4 USB cards right now) but I have been unable to get more than 2 cards working at a time.

Whenever I add a 3rd card (wlan3 for example) I get the following error:

"mac80211_setchannel() failed to connect to generic netlink"

I haven't been able to find any info on this error. I have googled, checked this forum and searched the Backtrack forums.

I've tried setting the sources via both the Kismet_UI and the kismet.conf file, and still get the same error when I try to add a 3rd card. I have tried to specify "type=rt73" in the kismet.conf, and also tried without creating a VAP (forcevap=f) which didn't change the error.

All the cards are the same: TP-Link WN321G USB using RT73 module. My O/S is BT4 pre-final, updated/upgraded as of Dec 19th.

I don't have any of these cards connected to an existing AP or have any IP assigned and I have also tested each of the 4 cards individually with newcore, and they all appear to work/collect packets.

Any suggestions are greatly appreciated.

Regards,

cybrsnpr


Reply to this message