Kismet Wireless

Kismet Forums

 

Posted by:andre
Subject:Kismet-2009-11-R1 on the N900
Date:21:40:34 18/12/2009

hi,
i'm trying to port kismet and gpsd to the n900. both compiled well and are working for their own, but as soon as i start the kismet_server the gpsd device paired to the n900 loses his connection.

There is a blue light on the gps receiver (a navilink bt-359 -they are sold under a diffent vendor name in the states) that indicates the bluetooth status on the device i.e. slow blinking for no connection and faster blinking for an established one.

normally, i use a little shellscipt to pair the device and start kismet:

"rfcomm bind /dev/rfcomm0 00:de:ad:be:ef:00 && sleep 15 & gpsd /dev/rfcomm0 & kismet" (this works for me on the nokia 770)

when the kismet-server gets started, the blue light flashes for 2-3 seconds (way longer than normal), then stops blinking for 4-5 seconds (also way longer than normal) and then it indicates no connection. if i try to start gpsd with the -b switch for a read only connection, it only stops blinking for 4-5 seconds, but also loses the rfcomm connection. gpsd runs fine but lost the connection to the device-link. i checked this with a telnet connection to the gpsd. I've also tried to fiddle around in the kismet.conf i.e. changing the "gpsmodelock" and "gpsreconnect" values, but nothing solved the problem.



This is reproducable with different versions of kismet and gpsd:

kismet-2009-11-r1
kismet-2009-06-r1
gpsd-2.90
gpsd-2.39

any idea how to fix this?

greetings from germany
andrè


Reply to this message