Kismet Wireless

Kismet Forums

 

Posted by:Thehaggs88
Subject:Sourcetype,interface,name issues
Date:18:32:11 01/12/2009

> > > > I am currently in the process of installing kismet on ubuntu 9.10 and my current problem is find exactly what the sourcetype and name for my card are. I know the interface is wlan0. I am using a realtek integrated wireless card, it supports monitor mode and I have turned monitor mode on.
> > > > The model # for the card is: WN6300L
> > > > After checking the realtek website The closest thing to a sourcetype I could find was RTL8225
> > > >
> > > > So if that is the correct Sourcetype then what im looking at now is
> > > > Source=RTL8225,wlan0,name
> > > >
> > > > I am still missing a name for it.
> > > >
> > > > My question is how do I find out the correct name for it or if I am just making up my own damn name and moving on.
> > > >
> > >
> > > Making up your own name
> > >
> > > > Any light shed on this will be helpful.
> > >
> > > You're using code a year out of date, however - 2009-11-R1 just released, and the 2009 releases are FAR simpler to configure, and actually supported. 2008 and previous are considered dead.
> > >
> > > You should upgrade to the latest.
> > >
> > > -m
> >
> > So I downloaded the latest version. I am new to Ubuntu so I am not so familiar with the commands. In the readme it says compile kismet with "make" I am assuming that "make" is some kind of compiler or a command in the terminal.
> > I tried using make as a command in the terminal but I don't think I have it right because what I have been trying is the command
> >
> > Make kismet
> >
> > And all I get is: make: ***no rule to make target "kismet". stop
> >
> > What rule do I need to make kismet?
> > I have looked on many forums and even read the Ubuntu pocket guide lol
>
> Here is what you should have to do, all of them in terminal/commandline:
>
> @:~$ sudo apt-get install libncurses5-dev libpcap-dev libnl-dev build-essential wireshark libpcre3-dev
> @:~$ wget http://www.kismetwireless.net/code/kismet-2009-11-R1.tar.gz
> @:~$ tar xzf kismet-2009-11-R1.tar.gz
> @:~$ cd kismet-2009-11-R1/
> @:~/kismet-2009-11-R1$ ./configure
> @:~/kismet-2009-11-R1$ make dep
> @:~/kismet-2009-11-R1$ make
> @:~/kismet-2009-11-R1$ sudo make suidinstall
>
> The first apt installs all the stuff you should need to successfully compile.


I am getting this error now..

checking for group 'man'... checking for initscr in -lncurses... no
checking for initscr in -lcurses... no
configure: error: Failed to find libcurses or libncurses. Install them or disable building the Kismet client with --disable-client. Disabling the client is probably not something you want to do normally.

Also when I entered
@:~$ sudo apt-get install libncurses5-dev libpcap-dev libnl-dev build-essential wireshark libpcre3-dev

I got this:
Reading package lists... Done
Building dependency tree
Reading state information... Done
build-essential is already the newest version.
wireshark is already the newest version.
wireshark set to manually installed.
sudo is already the newest version.
E: Couldn't find package apt-get <<<<<<<<<<<< This being my main concern


Reply to this message