Kismet Wireless

Kismet Forums

 

Posted by:dragorn
Subject:Kismet doesn't recognize libpcap1.0.0
Date:18:33:50 03/11/2009

> hello
>
> i tried to compile kismet 2009-06-R1 with libpcap1.0.
> ./configure gave me the following warning:
>
> checking for pcap_open_live in -lpcap... no
> configure: WARNING: Compiling without libpcap support.
>
> is there a problem with the new libpcap? a few days ago it compiled without any warnings but with the old libpcap.
>

Nope, no problems with 1.0.0.

dragorn@drd1813 ~/src/kismet $ ldd kismet_server
libpcap.so.1 => /usr/lib/libpcap.so.1 (0xb7614000)

lrwxrwxrwx 1 root root 1 May 26 13:48 /usr/lib/libpcap.so.1 -> libpcap.so.1.0.0*

I'm going to guess your buildroot is subtly screwed up - either you've got the wrong libpcap, a bad symlink, or mismatched headers is my guess.

Kismet doesn't take advantage of some of the newer APIs in libpcap (yet), but it works fine - also works fine with libpcap-cvs (been testing w/ both to isolate other bugs). It should "just go", nothing special is needed for it to be detected.

Check your config.log file and it will tell you exactly what failed in more detail, maybe that will point you in the right direction.

-m


Reply to this message