Kismet Wireless

Kismet Forums

 

Posted by:thepetmouse
Subject:Kismet old 2009 errors on "make"
Date:23:07:49 16/10/2009

> > > Running RHEL 4.8, and using Kismet Old 2009-05-R1
> > >
> > > When I run "make" I receive the following error:
> > >
> > > g++ -I/usr/local/include/ImageMagick -O2 -Wall -DVERSION_MAJOR=\"old-2009\" -DVERSION_MINOR=\"05\" -DVERSION_TINY=\"R1\" -DTIMESTAMP=\"`cat TIMESTAMP`\" -g -O2 -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include -I/usr/local/include/ImageMagick -c kismet_server.cc -o kismet_server.o
> > > In file included from kismet_server.cc:35:
> > > /usr/include/dbus-1.0/dbus/dbus.h:30:2: #error "Please define DBUS_API_SUBJECT_TO_CHANGE to acknowledge your understanding that D-BUS hasn't reached 1.0 and is subject to protocol and API churn. See the README for a full explanation."
> > > make: *** [kismet_server.o] Error 1
> > >
> > > Its telling me to look at the readme, but I still can't work it out.
> > >
> > > Any advice would be appreciated.
> >
> > Found old post which mentions installing ncurses headers
> >
> > Giving it a try.
>
> Looks like dbus broke their API again.
>
> Kismet-old isn't too likely to see an update, no promises about when I'll get around to building whatever broken dbus version that is, if ever.
>
> -m

Thanks for reply.
Ncurses already installed.
Dbus version is the primary release 1.2.16. Have I used the wrong version, the other being permissive?


Reply to this message