Kismet Wireless

Kismet Forums

 

Posted by:mm23
Subject:newcore and svn CPU/server problems
Date:10:04:52 19/09/2009

> > I've tried running both Kismet-2009-06-R1 and svn devel release with reasonably default configurations and with both iwl3945 and rtl8187 drivers/sources on a dual core Lenovo x60. In all cases, the server does not respond (after usual startup messages) and CPU use hits 100% with memory use slowly increasing to 50% after a few minutes. I've tried changing options such as channels and hopping without success.
>
> Sounds like a driver bug, definitely not seen anything like that. Will need detailed debug traces to do anything more.
>

From gdb it seems to be looping here:

#3 0xb7ea4695 in nl_recvmsgs () from /usr/lib/libnl.so.1
#4 0x0808872f in mac80211_get_chanlist (interface=0x97e624c "wlan1", chan_list=0xbfa32210, errstr=0xbfa31c3c "�006") at nl80211_control.cc:483

and in strace:

recvmsg(3, {msg_name(12)={sa_family=AF_NETLINK, pid=0, groups=00000000}, msg_iov(1)=[{"\344\3\0\0\25\0\2\0\207\254\264J\300M\0\0\3\1\0\0\10\0\1\0\1\0\0\0\t\0\2\0p"..., 4096}], msg_controllen=0, msg_flags=0}, 0) = 996

I hope that's enough information. Many thanks. M

> If you are running any plugins make sure you recompile them against the exact checkout used for the kismet_server binaries you're running.
>
> -m


Reply to this message