Kismet Wireless

Kismet Forums

 

Posted by:jparsell
Subject:Problem with getting kismet to work
Date:14:02:59 03/08/2009

Okay, so I know this question has probably been asked hundreds of times, but I'm new to Kismet (and have little experience in Linux) so please bare with me.

I recently installed kismet newcore on Red Hat Enterprise. I put my wireless card into monitor mode (Using an Orinoco Gold card by Lucent Technologies) and started up Kismet.

Now before I tell you what is happening, I want to say that I understand that the configuration file in the old Kismet had to be changed. After reading the README for the newcore version, it seems as though sources will automatically be added.

Okay, so after starting up kismet I get a message that says Kismet started with no packet sources defined. Then it asks if I would like to add a source now? I click yes and get the add source menu.

For Intf I put eth1 (specific to the card I'm using). For the name, I put Orinoco Gold. Options, i have been leaving blank because I'm not sure which options it means. Then I click add.

then i get a sources warning dialog box that says it has detected "orinoco_cs" driver for interface eth1, and that this driver will not report packets in rfmon under many firmware versions. it says kismet will continue to try and use it, but if i dont see packets, to consider changing firmware on card. I click ok.

Now, I can see networks for sure, and the menu on the side says that there are packets. But the packet graph only runs when Kismet first starts, shows me how many packets, and then never changes.

Also I keep seeing at the bottom of the screen:

INFO: Detected new managed network...
ERROR: Failed to set channel [different channels here]: Device or resource busy

Sorry my question is so long and that I have such little experience, I am just frustrated trying to get this to work.


Reply to this message